Notice: 11th May 2018

Running a 'yum update' or 'yum upgrade' at this time may cause SME components to break.

Appliance versions: 10.x, 1705.x, 1712.x, 1803.x

Storage Made Easy has recently become aware of an issue affecting customers who are updating their CentOS system packages for example by using the 'yum update' or 'yum upgrade' commands.

A component developed by an external vendor that the File Fabric uses called 'php-ioncube-loader' has a bug that's introduced in it's latest version 10.2.1. The File Fabric has been validated to be compatible with 10.2.0, however this recent update causes incompatibilities with the File Fabric.

The vendor who produces this component has now issued an update to this component.

Customers who have 10.2.1 of this component are encouraged to upgrade the package.

To check the version of 'php-ioncube-loader' you can run the following command.

yum list installed php-ioncube-loader

If it report that you are on 10.2.1, then you should upgrade it.

To upgrade the package, run the following:

yum update php-ioncube-loader

Now re-run the following command, and verify that you are on version 10.2.2 or newer.

yum list installed php-ioncube-loader

Update 16th July 2018: This notice has been updated to reflect that now version 10.2.2 has now become available, the process for resolving this is now an update of the php-ioncube-loader component rather than a downgrade.